ACFCS System Requirements
Share |

Operating Systems and Devices:

  • We standardize access to the Windows versions XP and above, and Mac OS X 10.5 (Leopard) and above
  • We will maintain active support for the 2 most recent public versions of Android and iOS device platforms. Most older versions will also function fine, however, to minimize the scope of possible QA and configuration support, we officially list the last 2 versions.

Browsers:

  • Internet Explorer: As of April 31st 2018, we support IE 11 and above in accordance with Microsoft support standards
  • Mozilla Firefox: (most recent 2 public versions).
  • Chrome and Safari: most recent 2 public versions. We also support learners on Safari and Google Chrome. Most older versions will also function fine, however, to minimize the scope of possible QA and configuration support, we officially list the last 2 versions.

Connection speed:

  • Connection speeds from standard broadband access will obviously improve learning experience within courseware itself.

Plug-Ins, Add-on Components, and Multimedia Support:

  • No required downloads for the Crowd Wisdom platform. However, courseware and learning materials requirements vary and will depend on the content itself and its publishers requirements. It is our experience that most e-learning courseware typically requires specific plug-ins such as Adobe Flash to view multimedia.
  • Clients leveraging a webinar integration may need their users to download the webinar platform to view webinars depending on the webinar provider.

Video:

  • Products listed as multimedia in ACFCS will use the popular video player, JW Player 7 and will start using JW player 8. This is the same player used by YouTube and most major websites. Should your organization produce video, we highly recommend the following settings as outlined by JW Player.

©2018 Association of Certified Financial Crime Specialists
All Rights Reserved